package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/)?(www\.)?(player\.)?vimeo\.com\/?(showcase\/)*([0-9))([a-z]*\/)*([0-9]{6,11})[?]?.*`)
var str = `http://player.vimeo.com/video/6701902
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}