re = /(https?:\/\/)?(www\.)?(player\.)?vimeo\.com\/?(showcase\/)*([0-9))([a-z]*\/)*([0-9]{6,11})[?]?.*/
str = 'http://player.vimeo.com/video/6701902
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end