package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.*?\])(.*)\[\/quote\]`)
var str = `[quote][quote][quote]a[/quote]b[/quote]c[/quote]
[quote user="vasya"][quote][quote]a[/quote]b[/quote]c[/quote]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}