$re = '/(^.*?\])(.*)\[\/quote\]/m';
$str = '[quote][quote][quote]a[/quote]b[/quote]c[/quote]
[quote user="vasya"][quote][quote]a[/quote]b[/quote]c[/quote]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);