package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)input\s+id="(?<id>.*?)("+?)(?:(\s+name="(?<name>.*)(.*?")))?`)
var str = `input id="txt" name="thistext"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}