re = /input\s+id="(?<id>.*?)("+?)(?:(\s+name="(?<name>.*)(.*?")))?/m
str = 'input id="txt" name="thistext"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end