import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/app1/(?!assets/)";
final String string = "/app1/\n"
+ "/app1/foo\n"
+ "/app1/bar\n"
+ "/app1/blah.html\n"
+ "/app1/assets/blah.js\n"
+ "/app1/assets/blah.js\n"
+ "/app1/assets/blah.css\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}