$re = '@^/app1/(?!assets/)@m';
$str = '/app1/
/app1/foo
/app1/bar
/app1/blah.html
/app1/assets/blah.js
/app1/assets/blah.js
/app1/assets/blah.css
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);