package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (.*) \(.*\[(.*)\]`)
var str = `By Patrick Traughber (@ptraughber), Product Manager [06:04 UTC]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}