use strict;
my $str = 'Não tem dois-pontos entre a chave e o valor
(não deveria dar match, mas dá)
{ "logUser" 123, "etc" ... } <-- JSON inválido
Isso abre brechas para termos algo assim:
{ "abc": ["logUser" , 123] } <-- não deveria dar match (logUser não é chave, é parte de um array)
Também aceita vários ":"
{ "logUser":::::::123, "etc" ... } <-- JSON inválido
---
Aceita "nada" entre os dois-pontos e a vírgula:
{ "logUser": , } <-- JSON inválido
---
E se tiver logUser no segundo nível?
{
"abc": 123,
"segundoNivel": {
"logUser": 123, <-- não deveria dar match, pois não está no primeiro nível
},
"logUser": 123, <-- deveria pegar só esse (e se desativar o flag "g", só iria pegar a ocorrência do segundo nível, pois ela aparece primeiro)
}
Lembre-se que um JSON não garante a ordem das chaves (é um unordered set), então ele pode ser retornado assim, dependendo das libs usadas.
---
A regex força ter uma vírgula no final, mas em um JSON as chaves não tem ordem, então deveria aceitar sem a vírgula também (vai que logUser é o último elemento):
{ "abc": 123, "logUser": "só aceita com vírgula no final", }
{ "abc": 123, "logUser": "mas deveria aceitar sem vírgula" }
';
my $regex = qr/\"logUser\"([\s\:]+)([^\,]*)(\,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}