# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"logUser\"([\s\:]+)([^\,]*)(\,)"
test_str = ("Não tem dois-pontos entre a chave e o valor\n"
"(não deveria dar match, mas dá)\n\n"
"{ \"logUser\" 123, \"etc\" ... } <-- JSON inválido\n\n"
"Isso abre brechas para termos algo assim:\n\n"
"{ \"abc\": [\"logUser\" , 123] } <-- não deveria dar match (logUser não é chave, é parte de um array)\n\n"
"Também aceita vários \":\"\n"
"{ \"logUser\":::::::123, \"etc\" ... } <-- JSON inválido\n\n"
"---\n"
"Aceita \"nada\" entre os dois-pontos e a vírgula:\n\n"
"{ \"logUser\": , } <-- JSON inválido\n\n"
"---\n"
"E se tiver logUser no segundo nível?\n\n"
"{\n"
" \"abc\": 123,\n"
" \"segundoNivel\": {\n"
" \"logUser\": 123, <-- não deveria dar match, pois não está no primeiro nível\n"
" },\n"
" \"logUser\": 123, <-- deveria pegar só esse (e se desativar o flag \"g\", só iria pegar a ocorrência do segundo nível, pois ela aparece primeiro)\n"
"}\n\n"
"Lembre-se que um JSON não garante a ordem das chaves (é um unordered set), então ele pode ser retornado assim, dependendo das libs usadas.\n\n"
"---\n"
"A regex força ter uma vírgula no final, mas em um JSON as chaves não tem ordem, então deveria aceitar sem a vírgula também (vai que logUser é o último elemento):\n\n"
"{ \"abc\": 123, \"logUser\": \"só aceita com vírgula no final\", }\n"
"{ \"abc\": 123, \"logUser\": \"mas deveria aceitar sem vírgula\" }\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.