import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d{0,3} ?[a-zA-Z]?(?: ?[/-] ?[1-9]\\d{0,3} ?[a-zA-Z]?)?$";
final String string = "############# valid ##########\n"
+ "12\n"
+ "12a\n"
+ "12A\n"
+ "12 A\n"
+ "12 a\n"
+ "12 b\n"
+ "12 z\n"
+ "121 b\n"
+ "56/58\n"
+ "56/58a\n"
+ "56-58\n"
+ "56 - 58\n"
+ "56-58a\n"
+ "1234\n"
+ "1234 a\n\n"
+ "56/58a\n"
+ "18a - 19b\n"
+ "18a-19b\n\n\n"
+ "############# not valid ##########\n"
+ "12345\n"
+ "25-ab\n"
+ "12ü\n"
+ "12_\n"
+ "asdfghjklöqwertzuioyxcvbnm\n"
+ "12!\"§$$%&/()\n"
+ "a2\n"
+ " a2\n"
+ "13àâäèéêë\n"
+ "0\n"
+ "123aaa123, \n"
+ "123 aaa 123 \n"
+ "1 a 1 \n"
+ "1a 1' \n"
+ "1a1 \n"
+ "13àâäèéêë\n"
+ "00 a\n"
+ "a a\n"
+ "00a\n"
+ "0a\n"
+ "12 ab 12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}