package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+(?:\-(?<letter>\w)\,?\s+)?(?:\-\-(?<name>\S+)(?:\[?[ =](?<value>\S+)\]?)?)?\s+(?<text>.*)$`)
var str = ` -v, --volume stringArray Bind mount a volume into the container (default [])
-h, --host=host run command on host (if supported by plugin)
-h, --help display help message and exit
-u with -lt: sort by, and show, access time; with -l: show access time and sort by name; otherwise: sort by access time, newest first
--time=WORD with -l, show time as WORD instead of default modification time: atime or access or use (-u); ctime or status (-c); also use specified time as sort key if --sort=time (newest first)
--color[=WHEN] colorize the output; WHEN can be 'always' (default if omitted), 'auto', or 'never'; more info below
--version output version information and exit
--volumes-from strings Mount volumes from the specified container(s) (default [])`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}