const regex = /^\s+(?:\-(?<letter>\w)\,?\s+)?(?:\-\-(?<name>\S+)(?:\[?[ =](?<value>\S+)\]?)?)?\s+(?<text>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+(?:\\-(?<letter>\\w)\\,?\\s+)?(?:\\-\\-(?<name>\\S+)(?:\\[?[ =](?<value>\\S+)\\]?)?)?\\s+(?<text>.*)$', 'gm')
const str = ` -v, --volume stringArray Bind mount a volume into the container (default [])
-h, --host=host run command on host (if supported by plugin)
-h, --help display help message and exit
-u with -lt: sort by, and show, access time; with -l: show access time and sort by name; otherwise: sort by access time, newest first
--time=WORD with -l, show time as WORD instead of default modification time: atime or access or use (-u); ctime or status (-c); also use specified time as sort key if --sort=time (newest first)
--color[=WHEN] colorize the output; WHEN can be 'always' (default if omitted), 'auto', or 'never'; more info below
--version output version information and exit
--volumes-from strings Mount volumes from the specified container(s) (default [])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}