$re = '/(?<!\\\\)"/';
$str = '$this \\"is\\" a "test"';
$subst = "\\\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;