import re
regex = re.compile(r"(?<!\\)\"")
test_str = "$this \\\"is\\\" a \"test\""
subst = "\\\\\""
result = regex.sub(subst, test_str)
if result:
print(result)