#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<![\w.])[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+)(?:[eE][+-]?\d+)?(?![\w.]))"
Local $sString = "input 1.5e8 100 1e8 1000e3 1. .2 .3e-3 -3 +3 abcd 1 192.168.100.1 1 192.168. 1 .129.12 1.5 .3ee 1 .3e+e 1 3fgh 1 .3sdf 1 asdf3 0 asdf3asdf -111.555e-100 +99.99e+99" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")