$re = '/((?<![\w.])[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+)(?:[eE][+-]?\d+)?(?![\w.]))/';
$str = 'input 1.5e8 100 1e8 1000e3 1. .2 .3e-3 -3 +3 abcd 1 192.168.100.1 1 192.168. 1 .129.12 1.5 .3ee 1 .3e+e 1 3fgh 1 .3sdf 1 asdf3 0 asdf3asdf -111.555e-100 +99.99e+99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);