import re
regex = re.compile(r"^(?:lundi|mardi|mercredi|jeudi|vendredi|samedi|dimanche) [0-3]?[0-9] (?:janvier|f[eé]vrier|mars|avril|mai|juin|juillet|ao[uû]t|septembre|octobre|novembre|d[eé]cembre) [0-9]{4} [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2}$", flags=re.IGNORECASE)
test_str = "Jeudi 3 avril 2014 16:23:00"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")