using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{8} ..:..:..).*orderID:\[(.*?)\].*sid:\[(.*?)\].*ticker:\[(.*?)\].*venue:\[(.*?)\].*lastFill:\[([1-9][0-9]*)\]";
string input = @"20160209 16:30:01:106.038 LOG_INFO Cancel rejected orderID:[QT_10581977_8] fixCancelID:[QT_10581977_8-C1] appType:[AGENCY_EQUITY] sid:[4550] ticker:[DLN LN] venue:[DARKBARC] side:[BUY] quantity:[235] disp:[0] min:[0] limit:[2952.000000] ct:[HYBRID] share:[0] tif:[DAY] type:[PEG_PASS] agg:[PASSIVE_DARK] locBrk:[] locID:[] set:[] idMktID:[0] status:[CANCELLED] rr:[] cr:[MARKET_CLOSED] execQty:[207] execPrice:[2970.536232] lastFill:[1]
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}