const regex = /(\d{8} ..:..:..).*orderID:\[(.*?)\].*sid:\[(.*?)\].*ticker:\[(.*?)\].*venue:\[(.*?)\].*lastFill:\[([1-9][0-9]*)\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{8} ..:..:..).*orderID:\\[(.*?)\\].*sid:\\[(.*?)\\].*ticker:\\[(.*?)\\].*venue:\\[(.*?)\\].*lastFill:\\[([1-9][0-9]*)\\]', '')
const str = `20160209 16:30:01:106.038 LOG_INFO Cancel rejected orderID:[QT_10581977_8] fixCancelID:[QT_10581977_8-C1] appType:[AGENCY_EQUITY] sid:[4550] ticker:[DLN LN] venue:[DARKBARC] side:[BUY] quantity:[235] disp:[0] min:[0] limit:[2952.000000] ct:[HYBRID] share:[0] tif:[DAY] type:[PEG_PASS] agg:[PASSIVE_DARK] locBrk:[] locID:[] set:[] idMktID:[0] status:[CANCELLED] rr:[] cr:[MARKET_CLOSED] execQty:[207] execPrice:[2970.536232] lastFill:[1]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}