package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z0-9_\.-])+([\da-z\.-]+)\.([a-z\.]{2,6})$`)
var str = `nameDomain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}