$re = '/^([a-z0-9_\.-])+([\da-z\.-]+)\.([a-z\.]{2,6})$/mi';
$str = 'nameDomain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);