#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((The Smithsonian|The Metropolitan)[^\.]*\.[^\.]*\.)"
Local $sString = "The Smithsonian museum is home to a variety of different art displays. According various reports art appreciation is on the rise. Blah blah blah blah.The Smithsonian museum blah blah blah. Blah blah blah blah."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")