re = /^((The Smithsonian|The Metropolitan)[^\.]*\.[^\.]*\.)/
str = 'The Smithsonian museum is home to a variety of different art displays. According various reports art appreciation is on the rise. Blah blah blah blah.The Smithsonian museum blah blah blah. Blah blah blah blah.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end