#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!-)\b\d+\b(?!-)"
Local $sString = "2016-03-29" & @CRLF & _
"7" & @CRLF & _
"46" & @CRLF & _
"8" & @CRLF & _
"43" & @CRLF & _
"9" & @CRLF & _
"47"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")