$re = '/(?<!-)\b\d+\b(?!-)/';
$str = '2016-03-29
7
46
8
43
9
47';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);