using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!""score"":(-)?[0-9].*)";
string substitution = @"$1";
string input = @"{""score"":0,""compare"":0,""words"":[""book"",""planet"",""sun"",""science""],""words"":[],""good"":[],""bad"":[]}
{""score"":-1,""compare"":0,""words"":[""book"",""planet"",""sun"",""science""],""words"":[],""good"":[],""bad"":[]}
{""score"":1,""compare"":0,""words"":[""book"",""planet"",""sun"",""science""],""words"":[],""good"":[],""bad"":[]}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}