re = /^(?!"score":(-)?[0-9].*)/m
str = '{"score":0,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":-1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result