# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.(?!"score":(-)?[0-9]))*/$1/gm;t' <<< "{\"score\":0,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":-1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}"