const regex = /(.(?!"score":(-)?[0-9]))*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.(?!"score":(-)?[0-9]))*', 'gm')
const str = `{"score":0,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":-1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}
{"score":1,"compare":0,"words":["book","planet","sun","science"],"words":[],"good":[],"bad":[]}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);