#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*at\s((?!webpack:).)*:\d+:\d+[\s\)]*\n"
Local $sString = "" & @CRLF & _
"/src/components/compare/couples/index.jsx" & @CRLF & _
"" & @CRLF & _
"/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/src/components/compare/couples/index.jsx" & @CRLF & _
" 23:5 error Parsing error: Unexpected token {" & @CRLF & _
"" & @CRLF & _
"✖ 1 problem (1 error, 0 warnings)" & @CRLF & _
"" & @CRLF & _
"BabelLoaderError: SyntaxError: Unexpected token (23:4)" & @CRLF & _
"" & @CRLF & _
" 21 | const Couples = ({products}) => (" & @CRLF & _
" 22 | <div>%%><" & @CRLF & _
"> 23 | {Foobar}" & @CRLF & _
" | ^" & @CRLF & _
" 24 | <Heading size="1">Couples</Heading>" & @CRLF & _
" 25 | <img className="banner" src={img}/>" & @CRLF & _
" 26 | <ul>" & @CRLF & _
"" & @CRLF & _
" at transpile (/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/index.js:52:13)" & @CRLF & _
" at /Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/lib/fs-cache.js:151:18" & @CRLF & _
" at ReadFileContext.callback (/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/lib/fs-cache.js:29:23)" & @CRLF & _
" at FSReqWrap.readFileAfterOpen [as oncomplete] (fs.js:303:13)" & @CRLF & _
"" & @CRLF & _
"static-react-render-webpack-plugin: Error rendering page "scripts/components/compare/couples.js": ReferenceError: Foobar is not defined" & @CRLF & _
" at Couples (webpack:///./components/compare/couples/index.jsx?:37:5)" & @CRLF & _
" at eval (webpack:///../~/react/lib/ReactCompositeComponent.js?:305:16)" & @CRLF & _
" at measureLifeCyclePerf (webpack:///../~/react/lib/ReactCompositeComponent.js?:74:12)" & @CRLF & _
" at ReactCompositeComponentMixin._constructComponentWithoutOwner (webpack:///../~/react/lib/ReactCompositeComponent.js?:304:14)" & @CRLF & _
" at ReactCompositeComponentMixin._constructComponent (webpack:///../~/react/lib/ReactCompositeComponent.js?:279:21)" & @CRLF & _
" at ReactCompositeComponentMixin.mountComponent (webpack:///../~/react/lib/ReactCompositeComponent.js?:187:21)" & @CRLF & _
" at Object.ReactReconciler.mountComponent (webpack:///../~/react/lib/ReactReconciler.js?:47:35)" & @CRLF & _
" at ReactDOMComponent.ReactMultiChild.Mixin.mountChildren (webpack:///../~/react/lib/ReactMultiChild.js?:240:44)" & @CRLF & _
" at ReactDOMComponent.Mixin._createContentMarkup (webpack:///../~/react/lib/ReactDOMComponent.js?:661:32)" & @CRLF & _
" at ReactDOMComponent.Mixin.mountComponent (webpack:///../~/react/lib/ReactDOMComponent.js?:528:29)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")