$re = '/^\s*at\s((?!webpack:).)*:\d+:\d+[\s\)]*\n/m';
$str = '
/src/components/compare/couples/index.jsx
/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/src/components/compare/couples/index.jsx
23:5 error Parsing error: Unexpected token {
✖ 1 problem (1 error, 0 warnings)
BabelLoaderError: SyntaxError: Unexpected token (23:4)
21 | const Couples = ({products}) => (
22 | <div>%%><
> 23 | {Foobar}
| ^
24 | <Heading size="1">Couples</Heading>
25 | <img className="banner" src={img}/>
26 | <ul>
at transpile (/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/index.js:52:13)
at /Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/lib/fs-cache.js:151:18
at ReadFileContext.callback (/Users/james/Work/nib/GithubEnterprise/frontend/react-static-example/node_modules/babel-loader/lib/fs-cache.js:29:23)
at FSReqWrap.readFileAfterOpen [as oncomplete] (fs.js:303:13)
static-react-render-webpack-plugin: Error rendering page "scripts/components/compare/couples.js": ReferenceError: Foobar is not defined
at Couples (webpack:///./components/compare/couples/index.jsx?:37:5)
at eval (webpack:///../~/react/lib/ReactCompositeComponent.js?:305:16)
at measureLifeCyclePerf (webpack:///../~/react/lib/ReactCompositeComponent.js?:74:12)
at ReactCompositeComponentMixin._constructComponentWithoutOwner (webpack:///../~/react/lib/ReactCompositeComponent.js?:304:14)
at ReactCompositeComponentMixin._constructComponent (webpack:///../~/react/lib/ReactCompositeComponent.js?:279:21)
at ReactCompositeComponentMixin.mountComponent (webpack:///../~/react/lib/ReactCompositeComponent.js?:187:21)
at Object.ReactReconciler.mountComponent (webpack:///../~/react/lib/ReactReconciler.js?:47:35)
at ReactDOMComponent.ReactMultiChild.Mixin.mountChildren (webpack:///../~/react/lib/ReactMultiChild.js?:240:44)
at ReactDOMComponent.Mixin._createContentMarkup (webpack:///../~/react/lib/ReactDOMComponent.js?:661:32)
at ReactDOMComponent.Mixin.mountComponent (webpack:///../~/react/lib/ReactDOMComponent.js?:528:29)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);