package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)\[quote\](.*?)\[\/quote\]`)
var str = `Hello, this is
an example post with multiple [quote]quotes from famous[/quote] people
For example [quote]this one[/quote] and others`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}