re = /\[quote\](.*?)\[\/quote\]/i
str = 'Hello, this is
an example post with multiple [quote]quotes from famous[/quote] people
For example [quote]this one[/quote] and others'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end