import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!\\/\\/).)*while.+[\\s=(]each[\\s(]";
final String string = "// comments at the beginning of the file are removed\n\n"
+ "/*\n"
+ "Block comments are removed - easy peasy\n"
+ "*/\n\n"
+ "https://urls.are.preserved.for.you// and comments after them are removed\n"
+ "asdfasdf// the comment can bump right up to text\n"
+ "asdfasdf;// ...or a semicolon.\n\n"
+ "{\n"
+ " foo:// you will need a parser to remove this comment b/c it smells like a URL\n"
+ " \"bar\",// ...but not this one\n"
+ " boo: // ...or this one\n"
+ " \"who\"\n"
+ "}\n"
+ " while (list($key, $value) = each($_GET))\n"
+ "/* some code\n"
+ " while (list($key, $value) = each($_GET))\n"
+ " some code\n"
+ "*/\n"
+ "while (list($key, $value) = each($_GET))\n"
+ "// while (list($key, $value) = each($_GET))\n"
+ "//while (list($key, $value) = each($_GET))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}