import re
regex = re.compile(r"^(?:(?!\/\/).)*while.+[\s=(]each[\s(]", flags=re.MULTILINE)
test_str = ("// comments at the beginning of the file are removed\n\n"
"/*\n"
"Block comments are removed - easy peasy\n"
"*/\n\n"
"https://urls.are.preserved.for.you// and comments after them are removed\n"
"asdfasdf// the comment can bump right up to text\n"
"asdfasdf;// ...or a semicolon.\n\n"
"{\n"
" foo:// you will need a parser to remove this comment b/c it smells like a URL\n"
" \"bar\",// ...but not this one\n"
" boo: // ...or this one\n"
" \"who\"\n"
"}\n"
" while (list($key, $value) = each($_GET))\n"
"/* some code\n"
" while (list($key, $value) = each($_GET))\n"
" some code\n"
"*/\n"
"while (list($key, $value) = each($_GET))\n"
"// while (list($key, $value) = each($_GET))\n"
"//while (list($key, $value) = each($_GET))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")