const regex = /([a-z]*_)([A-Z]{2})*/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]*_)([A-Z]{2})*', 'u')
const str = `es_ES`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}