$re = '/([a-z]*_)([A-Z]{2})*/u';
$str = 'es_ES';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);