#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)# Leap Years are any year that can be evenly divided by 4 " & @CRLF & _
"# (such as 2012, 2016, etc)" & @CRLF & _
"# • except if it can be evenly divided by 100" & @CRLF & _
"# then it isn't (such as 2100, 2200, etc)" & @CRLF & _
"# • except if it can be evenly divided by 400," & @CRLF & _
"# then it is (such as 2000, 2400)" & @CRLF & _
"# https://www.mathsisfun.com/leap-years.html" & @CRLF & _
"# -------------------------------------------------" & @CRLF & _
"# verify date dd/mm/yyyy; possible separators: -.,/" & @CRLF & _
"# valid year range: 0000-9999" & @CRLF & _
"" & @CRLF & _
"^ # start anchor" & @CRLF & _
"" & @CRLF & _
"# precheck xx-xx-xxxx,... add new separators here" & @CRLF & _
"(?=\d{2}([-.,\/])\d{2}\1\d{4}$)" & @CRLF & _
"" & @CRLF & _
"(?: # day-check: non caturing group" & @CRLF & _
"" & @CRLF & _
" # days 01-28" & @CRLF & _
" 0[1-9]|1\d|[2][0-8]| " & @CRLF & _
"" & @CRLF & _
" # february 29d check for leap year: all 4y / 00 years: only each 400" & @CRLF & _
" # 0400,0800,1200,1600,2000,..." & @CRLF & _
" 29" & @CRLF & _
" (?!.02. # not if feb: if not ..." & @CRLF & _
" (?!" & @CRLF & _
" # 00 years: exclude !0 %400 years" & @CRLF & _
" (?!(?:[02468][1-35-79]|[13579][0-13-57-9])00)" & @CRLF & _
"" & @CRLF & _
" # 00,04,08,12,... " & @CRLF & _
" \d{2}(?:[02468][048]|[13579][26])" & @CRLF & _
" )" & @CRLF & _
" )|" & @CRLF & _
"" & @CRLF & _
" # d30 negative lookahead: february cannot have 30 days" & @CRLF & _
" 30(?!.02)|" & @CRLF & _
"" & @CRLF & _
" # d31 positive lookahead: month up to 31 days" & @CRLF & _
" 31(?=.(?:0[13578]|10|12))" & @CRLF & _
"" & @CRLF & _
") # eof day-check" & @CRLF & _
"" & @CRLF & _
"# month 01-12" & @CRLF & _
".(?:0[1-9]|1[012])" & @CRLF & _
"" & @CRLF & _
"# year 0000-9999" & @CRLF & _
".\d{4}" & @CRLF & _
"" & @CRLF & _
"$ # end anchor"
Local $sString = "29/02/0000" & @CRLF & _
"29/02/0100" & @CRLF & _
"29/02/0200" & @CRLF & _
"29/02/0300" & @CRLF & _
"29/02/0400" & @CRLF & _
"29/02/0500" & @CRLF & _
"29/02/0600" & @CRLF & _
"29/02/0700" & @CRLF & _
"29/02/0800" & @CRLF & _
"29/02/0900" & @CRLF & _
"29/02/1000" & @CRLF & _
"29/02/1100" & @CRLF & _
"29/02/1200" & @CRLF & _
"29/02/1300" & @CRLF & _
"29/02/1400" & @CRLF & _
"29/02/1500" & @CRLF & _
"29/02/1600" & @CRLF & _
"29/02/1700" & @CRLF & _
"29/02/1800" & @CRLF & _
"29/02/1900" & @CRLF & _
"29/02/2000" & @CRLF & _
"29/02/2100" & @CRLF & _
"29/02/2200" & @CRLF & _
"29/02/2300" & @CRLF & _
"29/02/2400" & @CRLF & _
"29/02/2500"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")