// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)# Leap Years are any year that can be evenly divided by 4
# (such as 2012, 2016, etc)
# • except if it can be evenly divided by 100
# then it isn't (such as 2100, 2200, etc)
# • except if it can be evenly divided by 400,
# then it is (such as 2000, 2400)
# https://www.mathsisfun.com/leap-years.html
# -------------------------------------------------
# verify date dd/mm/yyyy; possible separators: -.,/
# valid year range: 0000-9999
^ # start anchor
# precheck xx-xx-xxxx,... add new separators here
(?=\d{2}([-.,\/])\d{2}\1\d{4}$)
(?: # day-check: non caturing group
# days 01-28
0[1-9]|1\d|[2][0-8]|
# february 29d check for leap year: all 4y / 00 years: only each 400
# 0400,0800,1200,1600,2000,...
29
(?!.02. # not if feb: if not ...
(?!
# 00 years: exclude !0 %400 years
(?!(?:[02468][1-35-79]|[13579][0-13-57-9])00)
# 00,04,08,12,...
\d{2}(?:[02468][048]|[13579][26])
)
)|
# d30 negative lookahead: february cannot have 30 days
30(?!.02)|
# d31 positive lookahead: month up to 31 days
31(?=.(?:0[13578]|10|12))
) # eof day-check
# month 01-12
.(?:0[1-9]|1[012])
# year 0000-9999
.\d{4}
$ # end anchor").unwrap();
let string = "29/02/0000
29/02/0100
29/02/0200
29/02/0300
29/02/0400
29/02/0500
29/02/0600
29/02/0700
29/02/0800
29/02/0900
29/02/1000
29/02/1100
29/02/1200
29/02/1300
29/02/1400
29/02/1500
29/02/1600
29/02/1700
29/02/1800
29/02/1900
29/02/2000
29/02/2100
29/02/2200
29/02/2300
29/02/2400
29/02/2500";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}