package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B@\w\S*\b`)
var str = `Now @Vasya comes up to @Tolya, @, @w,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}