$re = '/\B@\w\S*\b/';
$str = 'Now @Vasya comes up to @Tolya, @, @w,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);