package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]+)([=\s]+)([A-z0-9-]+)`)
var str = `ADFJE = 12313-asrn[5493]h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}