$re = '/^([A-Z]+)([=\s]+)([A-z0-9-]+)/m';
$str = 'ADFJE = 12313-asrn[5493]h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);