const regex = /(?<="NULL","0","0","0",",","1",",)(?:"([^"]+)",?)(?:"([^"]+)",?)?(?:"([^"]+)",?)?(?=,"D\$")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="NULL","0","0","0",",","1",",)(?:"([^"]+)",?)(?:"([^"]+)",?)?(?:"([^"]+)",?)?(?=,"D\\$")', 'gm')
const str = `"apple","NULL","0","0","0",",","1",","fruit","red","sweet","D\$","object"
"horse","NULL","0","0","0",",","1",","animal","large","tail","D\$","object"
"Los Angeles","NULL","0","0","0",",","1",","city","California","smoggy","entertainment","D\$","location"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}