re = /(?<="NULL","0","0","0",",","1",",)(?:"([^"]+)",?)(?:"([^"]+)",?)?(?:"([^"]+)",?)?(?=,"D\$")/m
str = '"apple","NULL","0","0","0",",","1",","fruit","red","sweet","D$","object"
"horse","NULL","0","0","0",",","1",","animal","large","tail","D$","object"
"Los Angeles","NULL","0","0","0",",","1",","city","California","smoggy","entertainment","D$","location"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end