package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(.*(\sAND\s|\sOR\s|!|~|>|<|=|>=|<=|<>|,|")+)|(\s*BLANK\s*$)`)
var str = `>1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}