$re = '/(.*(\sAND\s|\sOR\s|!|~|>|<|=|>=|<=|<>|,|")+)|(\s*BLANK\s*$)/i';
$str = '>1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);