use strict;
my $str = '<td id="yiv9101838563i4" style="padding:0;padding-top:25px;font-family:\'Segoe UI\', Tahoma, Verdana, Arial, sans-serif;font-size:14px;color:#2a2a2a;">Security code: <span style="font-family:\'Segoe UI Bold\', \'Segoe UI Semibold\', \'Segoe UI\', \'Helvetica Neue Medium\', Arial, sans-serif;font-size:14px;font-weight:bold;color:#2a2a2a;">7201</span></td>';
my $regex = qr/<td\s.*?>.*?<span\s.*?>(.*?)<\/span><\/td>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}